Skip to Content
Carnival’s Health & Sailing Update: Click here
Cookie Notice  This site uses cookies. By navigating this site, you agree to our use of cookies. You can learn more about our cookies on our page.
Support|0808 234 0680

Co-Browse Assistance

 

CO-BROWSE TERMS OF USE



BY CLICKING "I AGREE" OR OTHERWISE USING THIS CO-BROWSE SERVICE, YOU ARE AUTHORIZING CARNIVAL CORPORATION d/b/a CARNIVAL CRUISE LINE ("WE", "US" and "OUR") AND OUR AGENTS TO VIEW AND ACCESS YOUR WEB SESSION USING THIRD-PARTY SOFTWARE AND SERVICES (COLLECTIVELY, THE "SERVICE"). YOU AGREE THAT YOU SHALL REMAIN SOLELY RESPONSIBLE FOR ANY PURCHASES, BOOKINGS, OR CHARGES THAT ARE MADE OR INCURRED BY YOU DURING THIS SESSION AND FURTHER AGREE THAT CARNIVAL IS PROVIDING THIS SERVICE ONLY TO ASSIST GUESTS IN THEIR ONLINE BROWSING, BOOKING, AND REGISTRATION PROCESSES. YOU AGREE THAT YOU FULLY UNDERSTAND AND CONSENT TO BE BOUND BY THESE TERMS AND CONDITIONS, EFFECTIVE ON THE DATE YOU AGREE. YOU DO NOT AGREE WITH THESE TERMS AND CONDITIONS, YOU ARE NOT AUTHORIZED TO USE THE SERVICE AND YOU SHOULD IMMEDIATELY CLOSE THIS WINDOW AND THE BROWSER WINDOW CONTAINING THESE TERMS AND CONDITIONS. YOU SHOULD CAREFULLY REVIEW THESE TERMS AND CONDITIONS PRIOR TO USING THE SERVICE. YOU MAY END YOUR CURRENT USE OF THE SERVICE AT ANY TIME BY CLICKING THE "DISCONNECT" BUTTON OR CLOSING YOUR BROWSER WINDOW.

To activate your co-browse session, click the "Co-browse" link below. You may be required to click "Allow" or "Trust" through Java security messages. This co-browse technology works over encrypted SSL, and is powered by Oracle Right Now CX Cloud Service.

When the Co-browse technology launches, you will see a pop-up window with a 5 digit code. Give this code to your Contact Center agent, and they will activate the co-browse session.

REQUIREMENTS
To use our-cobrowse technology, you will need Sun Java browser plug-in version 1.5.0 or newer installed and active on your computer. You can verify if you have Java installed here: http://www.java.com/en/download/installed.jsp

Internet Explorer 7.0, 8.0, 9.0, 10 or 11
Chrome 14 or 15
Firefox 3.6, 4, 5, 6, or 7
Safari 5 or 5.1


CO-BROWSE WITH A LIVE AGENT
Co-browse